Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 22, 2025 - 08:00 GMT
Scheduled
Our Learner Hub application portal (apply.nottinghamcollege.ac.uk) will be undergoing scheduled maintenance for a routine software upgrade by our vendor Tribal.
During this software upgrade our Learner Hub application portal will be unavailable. This includes functions like logging into your account, viewing application progress and other actions.
As applying or enrolling onto courses also goes through our Learner Hub system, apply actions on the college website will also be temporarily suspended and replaced with a maintenance message during this period. This is because applications will be unable to be processed during the maintenance.
Further updates will be provided if required leading up to or during the maintenance period.
Posted Nov 20, 2025 - 14:04 GMT
This scheduled maintenance affected: Learner Hub (apply.nottinghamcollege.ac.uk, learnerhubrest.nottinghamcollege.ac.uk).