Increased 504 errors

Incident Report for Nottingham College

Postmortem

Our provider has investigated the issue that occurred and has provided a full report. The incident report can be viewed on our provider's status page.

The overall cause of the increased 504 errors was a DDoS flood attack that managed to bypass existing firewall and protection rules. As this traffic was not blocked at the WAF (web application firewall) level, it disrupted Craft Cloud applications, allowing DDoS flood traffic to pass through the firewall.

Craft Cloud has taken steps to increase resources in the Europe region to help mitigate future issues related to DDoS scenario. Further work is being carried out in the long term to improve resiliency and minimise further disruptions, including improving of detection if legitimate traffic as well as bot/DDoS traffic.

For requests that had been cached through the full-page static caching layer, these requests would have continued to be served without issues. Any request that is dynamic or not cached would have been impacted, given it would be impacted by increased latency due to the DDoS.

Posted Jul 17, 2025 - 08:18 BST

Resolved

The 504 errors appear to be resolved; further details on the cause will be provided in the post-mortem for reference.
Posted Jul 16, 2025 - 14:42 BST

Monitoring

Request response times are now improving, we will provide further details in the postmortem when we hear from our hosting provider.
Posted Jul 16, 2025 - 14:39 BST

Update

The issue appears to be related to our hosting provider experiencing an outage. The impact on our website is that any dynamic or non-cached requests appear to be very slow to respond or timeout with a 504 error.

This has been reported to our hosting provider for awareness and further investigation.
Posted Jul 16, 2025 - 14:33 BST

Investigating

We are currently aware of an increase in 504 errors impacting the college website, we are currently investigating the issue and will provide further details shortly.
Posted Jul 16, 2025 - 14:26 BST
This incident affected: College Website (www.nottinghamcollege.ac.uk).