Incorrect wage data being displayed on some apprenticeship vacancies
Incident Report for Nottingham College
Resolved
We are now displaying an specific information message about this issue on the relevant areas and will close off this incident. Our longer term solution will be to migrate to the newer APIs provided by the ESFA and Apprenticeship Service, however these are currently in early development and hence not suitable for production environments currently.
Posted Dec 20, 2021 - 17:14 GMT
Update
In response to this we are publishing an informational message on our apprenticeship vacancy listings to inform users of potential wage values being different. Again, we have no control over this issue and hope the Apprenticeship Service will amend their API. However, if this does not happen before transitioning to their new API, we will try and be as transparent as possible in regards to wage values being shown.
Posted Dec 20, 2021 - 16:29 GMT
Monitoring
We have been informed by the technical team at the Apprenticeships Service that they are aware of the wage difference issue. They have provided the following statement:

"This is a known issue and currently on a single backlog awaiting a fix for RAA V1

On some occasions Vacancy data service v1 API shows a different weekly wage to the front end RAA site 'weekly wage'.

This is due to the design of RAA V1. Currently as V1 is going to be decommissioned at some point in the future a fix is not prioritised."

We have expressed our views on this issue and are looking at temporary workarounds if the API is not fixed. However, Nottingham College is limited to what it can do given the API data is not under our control.

The Apprenticeship Service is developing new APIs which we will migrate to in due course which will resolve this issue, however these newer APIs are not currently available or production ready and therefore we have expressed that fixing the V1 API is preferable, despite a decommissioning date of March 2022 being set.
Posted Dec 20, 2021 - 15:50 GMT
Update
We are continuing to liaise with the technical team at the Apprenticeship Service to resolve this issue. We have provided various examples of this issue with their API and are awaiting their response.
Posted Dec 16, 2021 - 09:33 GMT
Identified
We are aware of a data issue with wage data displayed on some of our apprenticeship vacancies being different to what the National Apprenticeship Service (NAS) is showing on the Find an Apprenticeship service website.

This data is coming from an API which we have no direct control over. We have raised this with the NAS Helpdesk to query why we have wage data differences between their listings and their own API (which is our source of this information).

We are awaiting a response from their technical team and are continuing to provide further information to help understand this issue.

We apologise for the issue, please be aware when applying for an apprenticeship vacancy through the National Apprenticeship Service, the wage displayed on their listing before applying is the correct value.
Posted Dec 07, 2021 - 10:38 GMT